January 29, 2023

Edited: Shaurya Sharma

Final replace: January 24, 2023 at 11:31 AM IST

With this variation, customers won’t be able to obtain sure APK information.

The up to date Android 14 API necessities will quickly fully limit the set up of legacy apps.

Builders at the moment are required to focus on Android 12 or later for brand spanking new apps hosted on the Google Play Retailer, and beginning with Android 14, apps concentrating on legacy variations of Android can be fully restricted to cut back malware points.

Up to now, API minimal necessities have solely utilized to apps submitted to the Google Play Retailer, in line with a 9to5Google report. Builders can nonetheless create apps for older variations of Android and have customers manually set up the APK file utilizing sideloading. Nonetheless, the up to date Android 14 API necessities will fully limit the set up of legacy apps as per the latest code replace.

With this variation, customers won’t be able to obtain sure APK information and app shops won’t be able to put in these particular apps.

The report additionally states that Android 14 units will initially solely block apps that focus on “outdated variations of Android”, however this can later be expanded to incorporate Android 6.0 Marshmallow. But it surely’s seemingly that every machine producer can be free to decide on the cutoff for legacy apps, and even whether or not to incorporate it in any respect.

“If compelled minimal SDK set up model is enabled, block the set up of purposes that use a decrease goal SDK model than required. This helps enhance safety and privateness as a result of malware can goal older variations of the SDK to keep away from enforcement of recent API habits, Google stated in a developer put up. Google’s most important objective might be to begin preventing malware that infects units (together with older units) operating Android.

Learn all the newest tech information right here

Leave a Reply

Your email address will not be published.